2013年2月18日月曜日

zabbix2.0のインストール

zabbix2.0を試してみました。
以前インストールした1.8版はこちらになります。「zabbixのインストール 」

■関連のインストール
※RHEL6系の場合はipa-pgothic-fontsの代わりにvlgothic-p-fontsをインストールしてください
#CentOS 5用
# yum install curl net-snmp unixODBC OpenIPMI-libs ipa-pgothic-fonts
#CentOS 6用
# yum install curl net-snmp unixODBC OpenIPMI-libs vlgothic-p-fonts
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * base: ftp.nara.wide.ad.jp
 * centosplus: ftp.nara.wide.ad.jp
 * elrepo: repos.lax-noc.com
 * epel: ftp.iij.ad.jp
 * extras: ftp.nara.wide.ad.jp
 * rpmforge: mirror.fairway.ne.jp
 * updates: ftp.nara.wide.ad.jp
169 packages excluded due to repository priority protections
Setting up Install Process
Package curl-7.19.7-26.el6_2.4.x86_64 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package OpenIPMI-libs.x86_64 0:2.0.16-12.el6 will be installed
---> Package ipa-pgothic-fonts.noarch 0:003.02-4.1.el6 will be installed
--> Processing Dependency: fontpackages-filesystem for package: ipa-pgothic-fonts-003.02-4.1.el6.noarch
---> Package net-snmp.x86_64 1:5.5-41.el6 will be updated
---> Package net-snmp.x86_64 1:5.5-41.el6_3.1 will be an update
--> Processing Dependency: net-snmp-libs = 1:5.5-41.el6_3.1 for package: 1:net-snmp-5.5-41.el6_3.1.x86_64
---> Package unixODBC.x86_64 0:2.2.14-12.el6_3 will be installed
--> Processing Dependency: libltdl.so.7()(64bit) for package: unixODBC-2.2.14-12.el6_3.x86_64
--> Running transaction check
---> Package fontpackages-filesystem.noarch 0:1.41-1.1.el6 will be installed
---> Package libtool-ltdl.x86_64 0:2.2.6-15.5.el6 will be installed
---> Package net-snmp-libs.x86_64 1:5.5-41.el6 will be updated
--> Processing Dependency: net-snmp-libs = 1:5.5-41.el6 for package: 1:net-snmp-utils-5.5-41.el6.x86_64
---> Package net-snmp-libs.x86_64 1:5.5-41.el6_3.1 will be an update
--> Running transaction check
---> Package net-snmp-utils.x86_64 1:5.5-41.el6 will be updated
---> Package net-snmp-utils.x86_64 1:5.5-41.el6_3.1 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

====================================================================================================================================================================================
 Package                                              Arch                                Version                                        Repository                            Size
====================================================================================================================================================================================
Installing:
 OpenIPMI-libs                                        x86_64                              2.0.16-12.el6                                  base                                 475 k
 ipa-pgothic-fonts                                    noarch                              003.02-4.1.el6                                 base                                 3.6 M
 unixODBC                                             x86_64                              2.2.14-12.el6_3                                updates                              378 k
Updating:
 net-snmp                                             x86_64                              1:5.5-41.el6_3.1                               updates                              302 k
Installing for dependencies:
 fontpackages-filesystem                              noarch                              1.41-1.1.el6                                   base                                 8.8 k
 libtool-ltdl                                         x86_64                              2.2.6-15.5.el6                                 base                                  44 k
Updating for dependencies:
 net-snmp-libs                                        x86_64                              1:5.5-41.el6_3.1                               updates                              1.5 M
 net-snmp-utils                                       x86_64                              1:5.5-41.el6_3.1                               updates                              170 k

Transaction Summary
====================================================================================================================================================================================
Install       5 Package(s)
Upgrade       3 Package(s)

Total download size: 6.5 M
Is this ok [y/N]: y
Downloading Packages:
(1/8): OpenIPMI-libs-2.0.16-12.el6.x86_64.rpm                                                                                                                | 475 kB     00:00
(2/8): fontpackages-filesystem-1.41-1.1.el6.noarch.rpm                                                                                                       | 8.8 kB     00:00
(3/8): ipa-pgothic-fonts-003.02-4.1.el6.noarch.rpm                                                                                                           | 3.6 MB     00:00
(4/8): libtool-ltdl-2.2.6-15.5.el6.x86_64.rpm                                                                                                                |  44 kB     00:00
(5/8): net-snmp-5.5-41.el6_3.1.x86_64.rpm                                                                                                                    | 302 kB     00:00
(6/8): net-snmp-libs-5.5-41.el6_3.1.x86_64.rpm                                                                                                               | 1.5 MB     00:00
(7/8): net-snmp-utils-5.5-41.el6_3.1.x86_64.rpm                                                                                                              | 170 kB     00:00
(8/8): unixODBC-2.2.14-12.el6_3.x86_64.rpm                                                                                                                   | 378 kB     00:00
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                15 MB/s | 6.5 MB     00:00
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : 1:net-snmp-libs-5.5-41.el6_3.1.x86_64                                                                                                                           1/11
  Installing : libtool-ltdl-2.2.6-15.5.el6.x86_64                                                                                                                              2/11
  Installing : fontpackages-filesystem-1.41-1.1.el6.noarch                                                                                                                     3/11
  Installing : ipa-pgothic-fonts-003.02-4.1.el6.noarch                                                                                                                         4/11
  Installing : unixODBC-2.2.14-12.el6_3.x86_64                                                                                                                                 5/11
  Updating   : 1:net-snmp-5.5-41.el6_3.1.x86_64                                                                                                                                6/11
  Updating   : 1:net-snmp-utils-5.5-41.el6_3.1.x86_64                                                                                                                          7/11
  Installing : OpenIPMI-libs-2.0.16-12.el6.x86_64                                                                                                                              8/11
  Cleanup    : 1:net-snmp-utils-5.5-41.el6.x86_64                                                                                                                              9/11
  Cleanup    : 1:net-snmp-5.5-41.el6.x86_64                                                                                                                                   10/11
  Cleanup    : 1:net-snmp-libs-5.5-41.el6.x86_64                                                                                                                              11/11
  Verifying  : fontpackages-filesystem-1.41-1.1.el6.noarch                                                                                                                     1/11
  Verifying  : OpenIPMI-libs-2.0.16-12.el6.x86_64                                                                                                                              2/11
  Verifying  : 1:net-snmp-libs-5.5-41.el6_3.1.x86_64                                                                                                                           3/11
  Verifying  : unixODBC-2.2.14-12.el6_3.x86_64                                                                                                                                 4/11
  Verifying  : libtool-ltdl-2.2.6-15.5.el6.x86_64                                                                                                                              5/11
  Verifying  : 1:net-snmp-5.5-41.el6_3.1.x86_64                                                                                                                                6/11
  Verifying  : 1:net-snmp-utils-5.5-41.el6_3.1.x86_64                                                                                                                          7/11
  Verifying  : ipa-pgothic-fonts-003.02-4.1.el6.noarch                                                                                                                         8/11
  Verifying  : 1:net-snmp-5.5-41.el6.x86_64                                                                                                                                    9/11
  Verifying  : 1:net-snmp-utils-5.5-41.el6.x86_64                                                                                                                             10/11
  Verifying  : 1:net-snmp-libs-5.5-41.el6.x86_64                                                                                                                              11/11

Installed:
  OpenIPMI-libs.x86_64 0:2.0.16-12.el6                       ipa-pgothic-fonts.noarch 0:003.02-4.1.el6                       unixODBC.x86_64 0:2.2.14-12.el6_3

Dependency Installed:
  fontpackages-filesystem.noarch 0:1.41-1.1.el6                                                 libtool-ltdl.x86_64 0:2.2.6-15.5.el6

Updated:
  net-snmp.x86_64 1:5.5-41.el6_3.1

Dependency Updated:
  net-snmp-libs.x86_64 1:5.5-41.el6_3.1                                                    net-snmp-utils.x86_64 1:5.5-41.el6_3.1

Complete!
■PHP関連のインストール
# yum --enablerepo=remi install php php-devel php-bcmath php-gd php-mbstring php-mysql php-xml
Loaded plugins: fastestmirror, priorities
Determining fastest mirrors
epel/metalink                                                                                                                                                | 4.3 kB     00:00
 * base: ftp.nara.wide.ad.jp
 * centosplus: ftp.nara.wide.ad.jp
 * elrepo: repos.lax-noc.com
 * epel: ftp.iij.ad.jp
 * extras: ftp.nara.wide.ad.jp
 * remi: remi.mirrors.arminco.com
 * rpmforge: mirror.fairway.ne.jp
 * updates: ftp.nara.wide.ad.jp
base                                                                                                                                                         | 3.7 kB     00:00
centosplus                                                                                                                                                   | 3.5 kB     00:00
elrepo                                                                                                                                                       | 2.6 kB     00:00
elrepo/primary_db                                                                                                                                            | 507 kB     00:01
epel                                                                                                                                                         | 4.3 kB     00:00
epel/primary_db                                                                                                                                              | 5.0 MB     00:00
extras                                                                                                                                                       | 3.5 kB     00:00
remi                                                                                                                                                         | 2.9 kB     00:00
remi/primary_db                                                                                                                                              | 486 kB     00:01
rpmforge                                                                                                                                                     | 1.9 kB     00:00
updates                                                                                                                                                      | 3.5 kB     00:00
updates/primary_db                                                                                                                                           | 5.1 MB     00:00
vz-base                                                                                                                                                      |  951 B     00:00
vz-updates                                                                                                                                                   |  951 B     00:00
556 packages excluded due to repository priority protections
Setting up Install Process
Package php-5.4.11-1.el6.remi.x86_64 already installed and latest version
Package php-mbstring-5.4.11-1.el6.remi.x86_64 already installed and latest version
Package php-mysql-5.4.11-1.el6.remi.x86_64 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package php-bcmath.x86_64 0:5.4.11-1.el6.remi will be installed
---> Package php-devel.x86_64 0:5.4.11-1.el6.remi will be installed
--> Processing Dependency: automake for package: php-devel-5.4.11-1.el6.remi.x86_64
--> Processing Dependency: autoconf for package: php-devel-5.4.11-1.el6.remi.x86_64
---> Package php-gd.x86_64 0:5.4.11-1.el6.remi will be installed
--> Processing Dependency: libt1.so.5()(64bit) for package: php-gd-5.4.11-1.el6.remi.x86_64
--> Processing Dependency: libfreetype.so.6()(64bit) for package: php-gd-5.4.11-1.el6.remi.x86_64
--> Processing Dependency: libXpm.so.4()(64bit) for package: php-gd-5.4.11-1.el6.remi.x86_64
--> Processing Dependency: libX11.so.6()(64bit) for package: php-gd-5.4.11-1.el6.remi.x86_64
---> Package php-xml.x86_64 0:5.4.11-1.el6.remi will be installed
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.24)(64bit) for package: php-xml-5.4.11-1.el6.remi.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.22)(64bit) for package: php-xml-5.4.11-1.el6.remi.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.18)(64bit) for package: php-xml-5.4.11-1.el6.remi.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.13)(64bit) for package: php-xml-5.4.11-1.el6.remi.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.11)(64bit) for package: php-xml-5.4.11-1.el6.remi.x86_64
--> Processing Dependency: libxslt.so.1()(64bit) for package: php-xml-5.4.11-1.el6.remi.x86_64
--> Processing Dependency: libexslt.so.0()(64bit) for package: php-xml-5.4.11-1.el6.remi.x86_64
--> Running transaction check
---> Package autoconf.noarch 0:2.63-5.1.el6 will be installed
---> Package automake.noarch 0:1.11.1-1.2.el6 will be installed
---> Package freetype.x86_64 0:2.3.11-14.el6_3.1 will be installed
---> Package libX11.x86_64 0:1.3-2.el6 will be installed
--> Processing Dependency: libX11-common = 1.3-2.el6 for package: libX11-1.3-2.el6.x86_64
--> Processing Dependency: libxcb.so.1()(64bit) for package: libX11-1.3-2.el6.x86_64
---> Package libXpm.x86_64 0:3.5.8-2.el6 will be installed
---> Package libxslt.x86_64 0:1.1.26-2.el6_3.1 will be installed
---> Package t1lib.x86_64 0:5.1.2-6.el6_2.1 will be installed
--> Running transaction check
---> Package libX11-common.noarch 0:1.3-2.el6 will be installed
---> Package libxcb.x86_64 0:1.5-1.el6 will be installed
--> Processing Dependency: libXau.so.6()(64bit) for package: libxcb-1.5-1.el6.x86_64
--> Running transaction check
---> Package libXau.x86_64 0:1.0.5-1.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

====================================================================================================================================================================================
 Package                                      Arch                                  Version                                            Repository                              Size
====================================================================================================================================================================================
Installing:
 php-bcmath                                   x86_64                                5.4.11-1.el6.remi                                  remi                                    57 k
 php-devel                                    x86_64                                5.4.11-1.el6.remi                                  remi                                   2.5 M
 php-gd                                       x86_64                                5.4.11-1.el6.remi                                  remi                                   140 k
 php-xml                                      x86_64                                5.4.11-1.el6.remi                                  remi                                   167 k
Installing for dependencies:
 autoconf                                     noarch                                2.63-5.1.el6                                       base                                   781 k
 automake                                     noarch                                1.11.1-1.2.el6                                     base                                   550 k
 freetype                                     x86_64                                2.3.11-14.el6_3.1                                  updates                                359 k
 libX11                                       x86_64                                1.3-2.el6                                          base                                   582 k
 libX11-common                                noarch                                1.3-2.el6                                          base                                   188 k
 libXau                                       x86_64                                1.0.5-1.el6                                        base                                    22 k
 libXpm                                       x86_64                                3.5.8-2.el6                                        base                                    59 k
 libxcb                                       x86_64                                1.5-1.el6                                          base                                   100 k
 libxslt                                      x86_64                                1.1.26-2.el6_3.1                                   updates                                452 k
 t1lib                                        x86_64                                5.1.2-6.el6_2.1                                    base                                   160 k

Transaction Summary
====================================================================================================================================================================================
Install      14 Package(s)

Total download size: 6.1 M
Installed size: 25 M
Is this ok [y/N]: y
Downloading Packages:
(1/14): autoconf-2.63-5.1.el6.noarch.rpm                                                                                                                     | 781 kB     00:00
(2/14): automake-1.11.1-1.2.el6.noarch.rpm                                                                                                                   | 550 kB     00:00
(3/14): freetype-2.3.11-14.el6_3.1.x86_64.rpm                                                                                                                | 359 kB     00:00
(4/14): libX11-1.3-2.el6.x86_64.rpm                                                                                                                          | 582 kB     00:00
(5/14): libX11-common-1.3-2.el6.noarch.rpm                                                                                                                   | 188 kB     00:00
(6/14): libXau-1.0.5-1.el6.x86_64.rpm                                                                                                                        |  22 kB     00:00
(7/14): libXpm-3.5.8-2.el6.x86_64.rpm                                                                                                                        |  59 kB     00:00
(8/14): libxcb-1.5-1.el6.x86_64.rpm                                                                                                                          | 100 kB     00:00
(9/14): libxslt-1.1.26-2.el6_3.1.x86_64.rpm                                                                                                                  | 452 kB     00:00
(10/14): php-bcmath-5.4.11-1.el6.remi.x86_64.rpm                                                                                                             |  57 kB     00:00
(11/14): php-devel-5.4.11-1.el6.remi.x86_64.rpm                                                                                                              | 2.5 MB     00:08
(12/14): php-gd-5.4.11-1.el6.remi.x86_64.rpm                                                                                                                 | 140 kB     00:01
(13/14): php-xml-5.4.11-1.el6.remi.x86_64.rpm                                                                                                                | 167 kB     00:01
(14/14): t1lib-5.1.2-6.el6_2.1.x86_64.rpm                                                                                                                    | 160 kB     00:00
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                               456 kB/s | 6.1 MB     00:13
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : autoconf-2.63-5.1.el6.noarch                                                                                                                                    1/14
  Installing : automake-1.11.1-1.2.el6.noarch                                                                                                                                  2/14
  Installing : libxslt-1.1.26-2.el6_3.1.x86_64                                                                                                                                 3/14
  Installing : libX11-common-1.3-2.el6.noarch                                                                                                                                  4/14
  Installing : libXau-1.0.5-1.el6.x86_64                                                                                                                                       5/14
  Installing : libxcb-1.5-1.el6.x86_64                                                                                                                                         6/14
  Installing : libX11-1.3-2.el6.x86_64                                                                                                                                         7/14
  Installing : t1lib-5.1.2-6.el6_2.1.x86_64                                                                                                                                    8/14
  Installing : libXpm-3.5.8-2.el6.x86_64                                                                                                                                       9/14
  Installing : freetype-2.3.11-14.el6_3.1.x86_64                                                                                                                              10/14
  Installing : php-gd-5.4.11-1.el6.remi.x86_64                                                                                                                                11/14
  Installing : php-xml-5.4.11-1.el6.remi.x86_64                                                                                                                               12/14
  Installing : php-devel-5.4.11-1.el6.remi.x86_64                                                                                                                             13/14
  Installing : php-bcmath-5.4.11-1.el6.remi.x86_64                                                                                                                            14/14
  Verifying  : t1lib-5.1.2-6.el6_2.1.x86_64                                                                                                                                    1/14
  Verifying  : libX11-1.3-2.el6.x86_64                                                                                                                                         2/14
  Verifying  : libxcb-1.5-1.el6.x86_64                                                                                                                                         3/14
  Verifying  : php-gd-5.4.11-1.el6.remi.x86_64                                                                                                                                 4/14
  Verifying  : php-devel-5.4.11-1.el6.remi.x86_64                                                                                                                              5/14
  Verifying  : freetype-2.3.11-14.el6_3.1.x86_64                                                                                                                               6/14
  Verifying  : libXau-1.0.5-1.el6.x86_64                                                                                                                                       7/14
  Verifying  : autoconf-2.63-5.1.el6.noarch                                                                                                                                    8/14
  Verifying  : libX11-common-1.3-2.el6.noarch                                                                                                                                  9/14
  Verifying  : libxslt-1.1.26-2.el6_3.1.x86_64                                                                                                                                10/14
  Verifying  : php-xml-5.4.11-1.el6.remi.x86_64                                                                                                                               11/14
  Verifying  : automake-1.11.1-1.2.el6.noarch                                                                                                                                 12/14
  Verifying  : php-bcmath-5.4.11-1.el6.remi.x86_64                                                                                                                            13/14
  Verifying  : libXpm-3.5.8-2.el6.x86_64                                                                                                                                      14/14

Installed:
  php-bcmath.x86_64 0:5.4.11-1.el6.remi         php-devel.x86_64 0:5.4.11-1.el6.remi         php-gd.x86_64 0:5.4.11-1.el6.remi         php-xml.x86_64 0:5.4.11-1.el6.remi

Dependency Installed:
  autoconf.noarch 0:2.63-5.1.el6   automake.noarch 0:1.11.1-1.2.el6   freetype.x86_64 0:2.3.11-14.el6_3.1   libX11.x86_64 0:1.3-2.el6           libX11-common.noarch 0:1.3-2.el6
  libXau.x86_64 0:1.0.5-1.el6      libXpm.x86_64 0:3.5.8-2.el6        libxcb.x86_64 0:1.5-1.el6             libxslt.x86_64 0:1.1.26-2.el6_3.1   t1lib.x86_64 0:5.1.2-6.el6_2.1

Complete!
■MySQL関連のインストール
詳細なインストール方法はこちらの記事を参考にしてください。
MySQLのインストール
# yum --enablerepo=remi install mysql-server
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * base: ftp.nara.wide.ad.jp
 * centosplus: ftp.nara.wide.ad.jp
 * elrepo: repos.lax-noc.com
 * epel: ftp.iij.ad.jp
 * extras: ftp.nara.wide.ad.jp
 * remi: remi.mirrors.arminco.com
 * rpmforge: mirror.fairway.ne.jp
 * updates: ftp.nara.wide.ad.jp
556 packages excluded due to repository priority protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package mysql-server.x86_64 0:5.5.29-1.el6.remi will be updated
---> Package mysql-server.x86_64 0:5.5.30-1.el6.remi will be an update
--> Processing Dependency: mysql-libs(x86-64) = 5.5.30-1.el6.remi for package: mysql-server-5.5.30-1.el6.remi.x86_64
--> Processing Dependency: mysql(x86-64) = 5.5.30-1.el6.remi for package: mysql-server-5.5.30-1.el6.remi.x86_64
--> Running transaction check
---> Package mysql.x86_64 0:5.5.29-1.el6.remi will be updated
---> Package mysql.x86_64 0:5.5.30-1.el6.remi will be an update
---> Package mysql-libs.x86_64 0:5.5.29-1.el6.remi will be updated
---> Package mysql-libs.x86_64 0:5.5.30-1.el6.remi will be an update
--> Finished Dependency Resolution

Dependencies Resolved

====================================================================================================================================================================================
 Package                                      Arch                                   Version                                             Repository                            Size
====================================================================================================================================================================================
Updating:
 mysql-server                                 x86_64                                 5.5.30-1.el6.remi                                   remi                                  10 M
Updating for dependencies:
 mysql                                        x86_64                                 5.5.30-1.el6.remi                                   remi                                 5.7 M
 mysql-libs                                   x86_64                                 5.5.30-1.el6.remi                                   remi                                 773 k

Transaction Summary
====================================================================================================================================================================================
Upgrade       3 Package(s)

Total download size: 17 M
Is this ok [y/N]: y
Downloading Packages:
(1/3): mysql-5.5.30-1.el6.remi.x86_64.rpm                                                                                                                    | 5.7 MB     00:19
(2/3): mysql-libs-5.5.30-1.el6.remi.x86_64.rpm                                                                                                               | 773 kB     00:03
(3/3): mysql-server-5.5.30-1.el6.remi.x86_64.rpm                                                                                                             |  10 MB     00:33
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                               293 kB/s |  17 MB     00:57
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Warning: RPMDB altered outside of yum.
  Updating   : mysql-libs-5.5.30-1.el6.remi.x86_64                                                                                                                              1/6

WARNING : This MySQL RPM is not an official Fedora / Red Hat build and it
overrides the official one. Don't file bugs on Fedora Project nor Red Hat.
Use dedicated forums http://forums.famillecollet.com/

warning: /etc/my.cnf created as /etc/my.cnf.rpmnew
  Updating   : mysql-5.5.30-1.el6.remi.x86_64                                                                                                                                   2/6
  Updating   : mysql-server-5.5.30-1.el6.remi.x86_64                                                                                                                            3/6
  Cleanup    : mysql-server-5.5.29-1.el6.remi.x86_64                                                                                                                            4/6
  Cleanup    : mysql-5.5.29-1.el6.remi.x86_64                                                                                                                                   5/6
  Cleanup    : mysql-libs-5.5.29-1.el6.remi.x86_64                                                                                                                              6/6
  Verifying  : mysql-server-5.5.30-1.el6.remi.x86_64                                                                                                                            1/6
  Verifying  : mysql-5.5.30-1.el6.remi.x86_64                                                                                                                                   2/6
  Verifying  : mysql-libs-5.5.30-1.el6.remi.x86_64                                                                                                                              3/6
  Verifying  : mysql-libs-5.5.29-1.el6.remi.x86_64                                                                                                                              4/6
  Verifying  : mysql-5.5.29-1.el6.remi.x86_64                                                                                                                                   5/6
  Verifying  : mysql-server-5.5.29-1.el6.remi.x86_64                                                                                                                            6/6

Updated:
  mysql-server.x86_64 0:5.5.30-1.el6.remi

Dependency Updated:
  mysql.x86_64 0:5.5.30-1.el6.remi                                                       mysql-libs.x86_64 0:5.5.30-1.el6.remi

Complete!
■zabbixのyumリポジトリをインストールする
uname -r
2.6.32-042stab063.2
zabbix用のrpmをダウンロードする

・CentOS 5 64bit版
http://www.zabbix.jp/binaries/relatedpkgs/rhel5/x86_64/zabbix-jp-release-5-5.noarch.rpm

・CentOS 6 64bit版
http://www.zabbix.jp/binaries/relatedpkgs/rhel6/x86_64/zabbix-jp-release-6-5.noarch.rpm

パッケージのダウンロード
#CentOS 6 64bit版
# wget http://repo.zabbix.com/zabbix/2.0/rhel/6/x86_64/zabbix-jp-release-6-5.noarch.rpm
--2013-02-16 14:36:38--  http://www.zabbix.jp/binaries/relatedpkgs/rhel6/x86_64/zabbix-jp-release-6-5.noarch.rpm
www.zabbix.jp をDNSに問いあわせています... 66.117.3.248
www.zabbix.jp|66.117.3.248|:80 に接続しています... 接続しました。
HTTP による接続要求を送信しました、応答を待っています... 200 OK
長さ: 13752 (13K) [text/plain]
`zabbix-jp-release-6-5.noarch.rpm' に保存中

100%[==========================================================================================================================================>] 13,752      --.-K/s 時間 0.1s

2013-02-16 14:36:39 (104 KB/s) - `zabbix-jp-release-6-5.noarch.rpm' へ保存完了 [13752/13752]
パッケージのインストール
# rpm -ivh zabbix-jp-release-6-5.noarch.rpm
警告: zabbix-jp-release-6-5.noarch.rpm: ヘッダ V4 DSA/SHA1 Signature, key ID f32904ff: NOKEY
準備中...                ########################################### [100%]
   1:zabbix-jp-release      ########################################### [100%]
■必要なソフトウェアをインストールする
Zabbix Java Gateway機能を使いたい場合には、
yum install java-1.6.0-openjdkが必須?
# yum install fping iksemel iksemel-devel iksemel-utils libssh2 dejavu-sans-fonts java-1.6.0-openjdk
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * base: ftp.nara.wide.ad.jp
 * centosplus: ftp.nara.wide.ad.jp
 * elrepo: repos.lax-noc.com
 * epel: ftp.iij.ad.jp
 * extras: ftp.nara.wide.ad.jp
 * rpmforge: mirror.fairway.ne.jp
 * updates: ftp.nara.wide.ad.jp
169 packages excluded due to repository priority protections
Setting up Install Process
Package libssh2-1.2.2-11.el6_3.x86_64 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package dejavu-sans-fonts.noarch 0:2.30-2.el6 will be installed
--> Processing Dependency: dejavu-fonts-common = 2.30-2.el6 for package: dejavu-sans-fonts-2.30-2.el6.noarch
---> Package fping.x86_64 0:3.1-1.el6.rf will be installed
---> Package iksemel.x86_64 0:1.4-2.el6.JP will be installed
---> Package iksemel-devel.x86_64 0:1.4-2.el6.JP will be installed
--> Processing Dependency: gnutls-devel for package: iksemel-devel-1.4-2.el6.JP.x86_64
---> Package iksemel-utils.x86_64 0:1.4-2.el6.JP will be installed
---> Package java-1.6.0-openjdk.x86_64 1:1.6.0.0-1.54.1.11.6.el6_3 will be installed
--> Processing Dependency: jpackage-utils >= 1.7.3-1jpp.2 for package: 1:java-1.6.0-openjdk-1.6.0.0-1.54.1.11.6.el6_3.x86_64
--> Processing Dependency: tzdata-java for package: 1:java-1.6.0-openjdk-1.6.0.0-1.54.1.11.6.el6_3.x86_64
--> Processing Dependency: rhino for package: 1:java-1.6.0-openjdk-1.6.0.0-1.54.1.11.6.el6_3.x86_64
--> Processing Dependency: libpulse.so.0(PULSE_0)(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.54.1.11.6.el6_3.x86_64
--> Processing Dependency: libasound.so.2(ALSA_0.9.0rc4)(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.54.1.11.6.el6_3.x86_64
--> Processing Dependency: libasound.so.2(ALSA_0.9)(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.54.1.11.6.el6_3.x86_64
--> Processing Dependency: fontconfig for package: 1:java-1.6.0-openjdk-1.6.0.0-1.54.1.11.6.el6_3.x86_64
--> Processing Dependency: libpulse.so.0()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.54.1.11.6.el6_3.x86_64
--> Processing Dependency: libgif.so.4()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.54.1.11.6.el6_3.x86_64
--> Processing Dependency: libasound.so.2()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.54.1.11.6.el6_3.x86_64
--> Processing Dependency: libXtst.so.6()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.54.1.11.6.el6_3.x86_64
--> Processing Dependency: libXrender.so.1()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.54.1.11.6.el6_3.x86_64
--> Processing Dependency: libXi.so.6()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.54.1.11.6.el6_3.x86_64
--> Processing Dependency: libXext.so.6()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.54.1.11.6.el6_3.x86_64
--> Running transaction check
---> Package alsa-lib.x86_64 0:1.0.22-3.el6 will be installed
---> Package dejavu-fonts-common.noarch 0:2.30-2.el6 will be installed
---> Package fontconfig.x86_64 0:2.8.0-3.el6 will be installed
---> Package giflib.x86_64 0:4.1.6-3.1.el6 will be installed
--> Processing Dependency: libSM.so.6()(64bit) for package: giflib-4.1.6-3.1.el6.x86_64
--> Processing Dependency: libICE.so.6()(64bit) for package: giflib-4.1.6-3.1.el6.x86_64
---> Package gnutls-devel.x86_64 0:2.8.5-4.el6_2.2 will be installed
--> Processing Dependency: libgcrypt-devel for package: gnutls-devel-2.8.5-4.el6_2.2.x86_64
---> Package jpackage-utils.noarch 0:1.7.5-3.12.el6 will be installed
---> Package libXext.x86_64 0:1.1-3.el6 will be installed
---> Package libXi.x86_64 0:1.3-3.el6 will be installed
---> Package libXrender.x86_64 0:0.9.5-1.el6 will be installed
---> Package libXtst.x86_64 0:1.0.99.2-3.el6 will be installed
---> Package pulseaudio-libs.x86_64 0:0.9.21-14.el6_3 will be installed
--> Processing Dependency: libsndfile.so.1(libsndfile.so.1.0)(64bit) for package: pulseaudio-libs-0.9.21-14.el6_3.x86_64
--> Processing Dependency: libsndfile.so.1()(64bit) for package: pulseaudio-libs-0.9.21-14.el6_3.x86_64
--> Processing Dependency: libasyncns.so.0()(64bit) for package: pulseaudio-libs-0.9.21-14.el6_3.x86_64
---> Package rhino.noarch 0:1.7-0.7.r2.2.el6 will be installed
--> Processing Dependency: jline for package: rhino-1.7-0.7.r2.2.el6.noarch
---> Package tzdata-java.noarch 0:2012j-1.el6 will be installed
--> Running transaction check
---> Package jline.noarch 0:0.9.94-0.8.el6 will be installed
---> Package libICE.x86_64 0:1.0.6-1.el6 will be installed
---> Package libSM.x86_64 0:1.1.0-7.1.el6 will be installed
---> Package libasyncns.x86_64 0:0.8-1.1.el6 will be installed
---> Package libgcrypt-devel.x86_64 0:1.4.5-9.el6_2.2 will be installed
--> Processing Dependency: libgpg-error-devel for package: libgcrypt-devel-1.4.5-9.el6_2.2.x86_64
---> Package libsndfile.x86_64 0:1.0.20-5.el6 will be installed
--> Processing Dependency: libvorbisenc.so.2()(64bit) for package: libsndfile-1.0.20-5.el6.x86_64
--> Processing Dependency: libvorbis.so.0()(64bit) for package: libsndfile-1.0.20-5.el6.x86_64
--> Processing Dependency: libogg.so.0()(64bit) for package: libsndfile-1.0.20-5.el6.x86_64
--> Processing Dependency: libFLAC.so.8()(64bit) for package: libsndfile-1.0.20-5.el6.x86_64
--> Running transaction check
---> Package flac.x86_64 0:1.2.1-6.1.el6 will be installed
---> Package libgpg-error-devel.x86_64 0:1.7-4.el6 will be installed
---> Package libogg.x86_64 2:1.1.4-2.1.el6 will be installed
---> Package libvorbis.x86_64 1:1.2.3-4.el6_2.1 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

====================================================================================================================================================================================
 Package                                     Arch                           Version                                             Repository                                     Size
====================================================================================================================================================================================
Installing:
 dejavu-sans-fonts                           noarch                         2.30-2.el6                                          base                                          1.7 M
 fping                                       x86_64                         3.1-1.el6.rf                                        rpmforge                                       45 k
 iksemel                                     x86_64                         1.4-2.el6.JP                                        zabbix-jp-relatedpkgs                          47 k
 iksemel-devel                               x86_64                         1.4-2.el6.JP                                        zabbix-jp-relatedpkgs                          34 k
 iksemel-utils                               x86_64                         1.4-2.el6.JP                                        zabbix-jp-relatedpkgs                          25 k
 java-1.6.0-openjdk                          x86_64                         1:1.6.0.0-1.54.1.11.6.el6_3                         updates                                        25 M
Installing for dependencies:
 alsa-lib                                    x86_64                         1.0.22-3.el6                                        base                                          370 k
 dejavu-fonts-common                         noarch                         2.30-2.el6                                          base                                           59 k
 flac                                        x86_64                         1.2.1-6.1.el6                                       base                                          243 k
 fontconfig                                  x86_64                         2.8.0-3.el6                                         base                                          186 k
 giflib                                      x86_64                         4.1.6-3.1.el6                                       base                                           37 k
 gnutls-devel                                x86_64                         2.8.5-4.el6_2.2                                     base                                          1.1 M
 jline                                       noarch                         0.9.94-0.8.el6                                      base                                           86 k
 jpackage-utils                              noarch                         1.7.5-3.12.el6                                      base                                           59 k
 libICE                                      x86_64                         1.0.6-1.el6                                         base                                           53 k
 libSM                                       x86_64                         1.1.0-7.1.el6                                       base                                           26 k
 libXext                                     x86_64                         1.1-3.el6                                           base                                           33 k
 libXi                                       x86_64                         1.3-3.el6                                           base                                           32 k
 libXrender                                  x86_64                         0.9.5-1.el6                                         base                                           27 k
 libXtst                                     x86_64                         1.0.99.2-3.el6                                      base                                           22 k
 libasyncns                                  x86_64                         0.8-1.1.el6                                         base                                           24 k
 libgcrypt-devel                             x86_64                         1.4.5-9.el6_2.2                                     base                                          118 k
 libgpg-error-devel                          x86_64                         1.7-4.el6                                           base                                           14 k
 libogg                                      x86_64                         2:1.1.4-2.1.el6                                     base                                           21 k
 libsndfile                                  x86_64                         1.0.20-5.el6                                        base                                          233 k
 libvorbis                                   x86_64                         1:1.2.3-4.el6_2.1                                   base                                          168 k
 pulseaudio-libs                             x86_64                         0.9.21-14.el6_3                                     updates                                       462 k
 rhino                                       noarch                         1.7-0.7.r2.2.el6                                    base                                          778 k
 tzdata-java                                 noarch                         2012j-1.el6                                         updates                                       155 k

Transaction Summary
====================================================================================================================================================================================
Install      29 Package(s)

Total download size: 31 M
Installed size: 96 M
Is this ok [y/N]: y
Downloading Packages:
(1/29): alsa-lib-1.0.22-3.el6.x86_64.rpm                                                                                                                     | 370 kB     00:00
(2/29): dejavu-fonts-common-2.30-2.el6.noarch.rpm                                                                                                            |  59 kB     00:00
(3/29): dejavu-sans-fonts-2.30-2.el6.noarch.rpm                                                                                                              | 1.7 MB     00:00
(4/29): flac-1.2.1-6.1.el6.x86_64.rpm                                                                                                                        | 243 kB     00:00
(5/29): fontconfig-2.8.0-3.el6.x86_64.rpm                                                                                                                    | 186 kB     00:00
(6/29): fping-3.1-1.el6.rf.x86_64.rpm                                                                                                                        |  45 kB     00:00
(7/29): giflib-4.1.6-3.1.el6.x86_64.rpm                                                                                                                      |  37 kB     00:00
(8/29): gnutls-devel-2.8.5-4.el6_2.2.x86_64.rpm                                                                                                              | 1.1 MB     00:00
(9/29): iksemel-1.4-2.el6.JP.x86_64.rpm                                                                                                                      |  47 kB     00:00
(10/29): iksemel-devel-1.4-2.el6.JP.x86_64.rpm                                                                                                               |  34 kB     00:00
(11/29): iksemel-utils-1.4-2.el6.JP.x86_64.rpm                                                                                                               |  25 kB     00:00
(12/29): java-1.6.0-openjdk-1.6.0.0-1.54.1.11.6.el6_3.x86_64.rpm                                                                                             |  25 MB     00:01
(13/29): jline-0.9.94-0.8.el6.noarch.rpm                                                                                                                     |  86 kB     00:00
(14/29): jpackage-utils-1.7.5-3.12.el6.noarch.rpm                                                                                                            |  59 kB     00:00
(15/29): libICE-1.0.6-1.el6.x86_64.rpm                                                                                                                       |  53 kB     00:00
(16/29): libSM-1.1.0-7.1.el6.x86_64.rpm                                                                                                                      |  26 kB     00:00
(17/29): libXext-1.1-3.el6.x86_64.rpm                                                                                                                        |  33 kB     00:00
(18/29): libXi-1.3-3.el6.x86_64.rpm                                                                                                                          |  32 kB     00:00
(19/29): libXrender-0.9.5-1.el6.x86_64.rpm                                                                                                                   |  27 kB     00:00
(20/29): libXtst-1.0.99.2-3.el6.x86_64.rpm                                                                                                                   |  22 kB     00:00
(21/29): libasyncns-0.8-1.1.el6.x86_64.rpm                                                                                                                   |  24 kB     00:00
(22/29): libgcrypt-devel-1.4.5-9.el6_2.2.x86_64.rpm                                                                                                          | 118 kB     00:00
(23/29): libgpg-error-devel-1.7-4.el6.x86_64.rpm                                                                                                             |  14 kB     00:00
(24/29): libogg-1.1.4-2.1.el6.x86_64.rpm                                                                                                                     |  21 kB     00:00
(25/29): libsndfile-1.0.20-5.el6.x86_64.rpm                                                                                                                  | 233 kB     00:00
(26/29): libvorbis-1.2.3-4.el6_2.1.x86_64.rpm                                                                                                                | 168 kB     00:00
(27/29): pulseaudio-libs-0.9.21-14.el6_3.x86_64.rpm                                                                                                          | 462 kB     00:00
(28/29): rhino-1.7-0.7.r2.2.el6.noarch.rpm                                                                                                                   | 778 kB     00:00
(29/29): tzdata-java-2012j-1.el6.noarch.rpm                                                                                                                  | 155 kB     00:00
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                11 MB/s |  31 MB     00:02
warning: rpmts_HdrFromFdno: Header V4 DSA/SHA1 Signature, key ID f32904ff: NOKEY
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-ZABBIX-JP
Importing GPG key 0xF32904FF:
 Userid : ZABBIX-JP (Japanese ZABBIX Support Site) 
 Package: zabbix-jp-release-6-5.noarch (installed)
 From   : /etc/pki/rpm-gpg/RPM-GPG-KEY-ZABBIX-JP
Is this ok [y/N]: y
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : libICE-1.0.6-1.el6.x86_64                                                                                                                                       1/29
  Installing : libXext-1.1-3.el6.x86_64                                                                                                                                        2/29
  Installing : 2:libogg-1.1.4-2.1.el6.x86_64                                                                                                                                   3/29
  Installing : libXi-1.3-3.el6.x86_64                                                                                                                                          4/29
  Installing : libXtst-1.0.99.2-3.el6.x86_64                                                                                                                                   5/29
  Installing : libSM-1.1.0-7.1.el6.x86_64                                                                                                                                      6/29
  Installing : alsa-lib-1.0.22-3.el6.x86_64                                                                                                                                    7/29
  Installing : jpackage-utils-1.7.5-3.12.el6.noarch                                                                                                                            8/29
  Installing : iksemel-1.4-2.el6.JP.x86_64                                                                                                                                     9/29
  Installing : giflib-4.1.6-3.1.el6.x86_64                                                                                                                                    10/29
  Installing : 1:libvorbis-1.2.3-4.el6_2.1.x86_64                                                                                                                             11/29
  Installing : flac-1.2.1-6.1.el6.x86_64                                                                                                                                      12/29
  Installing : libsndfile-1.0.20-5.el6.x86_64                                                                                                                                 13/29
  Installing : libXrender-0.9.5-1.el6.x86_64                                                                                                                                  14/29
  Installing : dejavu-fonts-common-2.30-2.el6.noarch                                                                                                                          15/29
  Installing : jline-0.9.94-0.8.el6.noarch                                                                                                                                    16/29
  Installing : rhino-1.7-0.7.r2.2.el6.noarch                                                                                                                                  17/29
  Installing : tzdata-java-2012j-1.el6.noarch                                                                                                                                 18/29
  Installing : libgpg-error-devel-1.7-4.el6.x86_64                                                                                                                            19/29
  Installing : libgcrypt-devel-1.4.5-9.el6_2.2.x86_64                                                                                                                         20/29
  Installing : gnutls-devel-2.8.5-4.el6_2.2.x86_64                                                                                                                            21/29
  Installing : fontconfig-2.8.0-3.el6.x86_64                                                                                                                                  22/29
  Installing : libasyncns-0.8-1.1.el6.x86_64                                                                                                                                  23/29
  Installing : pulseaudio-libs-0.9.21-14.el6_3.x86_64                                                                                                                         24/29
  Installing : 1:java-1.6.0-openjdk-1.6.0.0-1.54.1.11.6.el6_3.x86_64                                                                                                          25/29
  Installing : iksemel-devel-1.4-2.el6.JP.x86_64                                                                                                                              26/29
install-info: warning: no info dir entry in `/usr/share/info/iksemel.info'
  Installing : dejavu-sans-fonts-2.30-2.el6.noarch                                                                                                                            27/29
  Installing : iksemel-utils-1.4-2.el6.JP.x86_64                                                                                                                              28/29
  Installing : fping-3.1-1.el6.rf.x86_64                                                                                                                                      29/29
  Verifying  : fping-3.1-1.el6.rf.x86_64                                                                                                                                       1/29
  Verifying  : 1:libvorbis-1.2.3-4.el6_2.1.x86_64                                                                                                                              2/29
  Verifying  : iksemel-1.4-2.el6.JP.x86_64                                                                                                                                     3/29
  Verifying  : libasyncns-0.8-1.1.el6.x86_64                                                                                                                                   4/29
  Verifying  : fontconfig-2.8.0-3.el6.x86_64                                                                                                                                   5/29
  Verifying  : rhino-1.7-0.7.r2.2.el6.noarch                                                                                                                                   6/29
  Verifying  : gnutls-devel-2.8.5-4.el6_2.2.x86_64                                                                                                                             7/29
  Verifying  : pulseaudio-libs-0.9.21-14.el6_3.x86_64                                                                                                                          8/29
  Verifying  : libgpg-error-devel-1.7-4.el6.x86_64                                                                                                                             9/29
  Verifying  : dejavu-sans-fonts-2.30-2.el6.noarch                                                                                                                            10/29
  Verifying  : tzdata-java-2012j-1.el6.noarch                                                                                                                                 11/29
  Verifying  : 2:libogg-1.1.4-2.1.el6.x86_64                                                                                                                                  12/29
  Verifying  : libSM-1.1.0-7.1.el6.x86_64                                                                                                                                     13/29
  Verifying  : libsndfile-1.0.20-5.el6.x86_64                                                                                                                                 14/29
  Verifying  : jpackage-utils-1.7.5-3.12.el6.noarch                                                                                                                           15/29
  Verifying  : jline-0.9.94-0.8.el6.noarch                                                                                                                                    16/29
  Verifying  : iksemel-utils-1.4-2.el6.JP.x86_64                                                                                                                              17/29
  Verifying  : libXi-1.3-3.el6.x86_64                                                                                                                                         18/29
  Verifying  : alsa-lib-1.0.22-3.el6.x86_64                                                                                                                                   19/29
  Verifying  : libgcrypt-devel-1.4.5-9.el6_2.2.x86_64                                                                                                                         20/29
  Verifying  : libXext-1.1-3.el6.x86_64                                                                                                                                       21/29
  Verifying  : dejavu-fonts-common-2.30-2.el6.noarch                                                                                                                          22/29
  Verifying  : iksemel-devel-1.4-2.el6.JP.x86_64                                                                                                                              23/29
  Verifying  : 1:java-1.6.0-openjdk-1.6.0.0-1.54.1.11.6.el6_3.x86_64                                                                                                          24/29
  Verifying  : flac-1.2.1-6.1.el6.x86_64                                                                                                                                      25/29
  Verifying  : libICE-1.0.6-1.el6.x86_64                                                                                                                                      26/29
  Verifying  : libXrender-0.9.5-1.el6.x86_64                                                                                                                                  27/29
  Verifying  : libXtst-1.0.99.2-3.el6.x86_64                                                                                                                                  28/29
  Verifying  : giflib-4.1.6-3.1.el6.x86_64                                                                                                                                    29/29

Installed:
  dejavu-sans-fonts.noarch 0:2.30-2.el6      fping.x86_64 0:3.1-1.el6.rf                                iksemel.x86_64 0:1.4-2.el6.JP      iksemel-devel.x86_64 0:1.4-2.el6.JP
  iksemel-utils.x86_64 0:1.4-2.el6.JP        java-1.6.0-openjdk.x86_64 1:1.6.0.0-1.54.1.11.6.el6_3

Dependency Installed:
  alsa-lib.x86_64 0:1.0.22-3.el6                 dejavu-fonts-common.noarch 0:2.30-2.el6       flac.x86_64 0:1.2.1-6.1.el6            fontconfig.x86_64 0:2.8.0-3.el6
  giflib.x86_64 0:4.1.6-3.1.el6                  gnutls-devel.x86_64 0:2.8.5-4.el6_2.2         jline.noarch 0:0.9.94-0.8.el6          jpackage-utils.noarch 0:1.7.5-3.12.el6
  libICE.x86_64 0:1.0.6-1.el6                    libSM.x86_64 0:1.1.0-7.1.el6                  libXext.x86_64 0:1.1-3.el6             libXi.x86_64 0:1.3-3.el6
  libXrender.x86_64 0:0.9.5-1.el6                libXtst.x86_64 0:1.0.99.2-3.el6               libasyncns.x86_64 0:0.8-1.1.el6        libgcrypt-devel.x86_64 0:1.4.5-9.el6_2.2
  libgpg-error-devel.x86_64 0:1.7-4.el6          libogg.x86_64 2:1.1.4-2.1.el6                 libsndfile.x86_64 0:1.0.20-5.el6       libvorbis.x86_64 1:1.2.3-4.el6_2.1
  pulseaudio-libs.x86_64 0:0.9.21-14.el6_3       rhino.noarch 0:1.7-0.7.r2.2.el6               tzdata-java.noarch 0:2012j-1.el6

Complete!


■Zabbixのインストール

最新版は2.0.5でした。
関連するZabbixパッケージのダウンロード

zabbixをダウンロード
# wget http://repo.zabbix.com/zabbix/2.0/rhel/6/x86_64/zabbix-2.0.5-1.el6.x86_64.rpm
--2013-02-16 14:59:59--  http://www.kodai74.net/packages/zabbix/zabbix-2.0/rhel/6/x86_64/zabbix-2.0.5-1.el6.x86_64.rpm
www.kodai74.net をDNSに問いあわせています... 66.117.3.248
www.kodai74.net|66.117.3.248|:80 に接続しています... 接続しました。
HTTP による接続要求を送信しました、応答を待っています... 200 OK
長さ: 120588 (118K) [text/plain]
`zabbix-2.0.5-1.el6.x86_64.rpm' に保存中

100%[==========================================================================================================================================>] 120,588      299K/s 時間 0.4s

2013-02-16 15:00:01 (299 KB/s) - `zabbix-2.0.5-1.el6.x86_64.rpm' へ保存完了 [120588/120588]
zabbix-agentをダウンロード
# wget http://repo.zabbix.com/zabbix/2.0/rhel/6/x86_64/zabbix-agent-2.0.5-1.el6.x86_64.rpm
--2013-02-16 15:00:13--  http://www.kodai74.net/packages/zabbix/zabbix-2.0/rhel/6/x86_64/zabbix-agent-2.0.5-1.el6.x86_64.rpm
www.kodai74.net をDNSに問いあわせています... 66.117.3.248
www.kodai74.net|66.117.3.248|:80 に接続しています... 接続しました。
HTTP による接続要求を送信しました、応答を待っています... 200 OK
長さ: 140372 (137K) [text/plain]
`zabbix-agent-2.0.5-1.el6.x86_64.rpm' に保存中

100%[==========================================================================================================================================>] 140,372      285K/s 時間 0.5s

2013-02-16 15:00:14 (285 KB/s) - `zabbix-agent-2.0.5-1.el6.x86_64.rpm' へ保存完了 [140372/140372]
zabbix-getコマンドをダウンロード
# wget http://repo.zabbix.com/zabbix/2.0/rhel/6/x86_64/zabbix-get-2.0.5-1.el6.x86_64.rpm
--2013-02-16 15:00:24--  http://www.kodai74.net/packages/zabbix/zabbix-2.0/rhel/6/x86_64/zabbix-get-2.0.5-1.el6.x86_64.rpm
www.kodai74.net をDNSに問いあわせています... 66.117.3.248
www.kodai74.net|66.117.3.248|:80 に接続しています... 接続しました。
HTTP による接続要求を送信しました、応答を待っています... 200 OK
長さ: 50396 (49K) [text/plain]
`zabbix-get-2.0.5-1.el6.x86_64.rpm' に保存中

100%[==========================================================================================================================================>] 50,396       205K/s 時間 0.2s

2013-02-16 15:00:25 (205 KB/s) - `zabbix-get-2.0.5-1.el6.x86_64.rpm' へ保存完了 [50396/50396]
zabbix-java-gatewayをダウンロード
# wget http://repo.zabbix.com/zabbix/2.0/rhel/6/x86_64/zabbix-java-gateway-2.0.5-1.el6.x86_64.rpm
--2013-02-16 15:00:31--  http://www.kodai74.net/packages/zabbix/zabbix-2.0/rhel/6/x86_64/zabbix-java-gateway-2.0.5-1.el6.x86_64.rpm
www.kodai74.net をDNSに問いあわせています... 66.117.3.248
www.kodai74.net|66.117.3.248|:80 に接続しています... 接続しました。
HTTP による接続要求を送信しました、応答を待っています... 200 OK
長さ: 565728 (552K) [text/plain]
`zabbix-java-gateway-2.0.5-1.el6.x86_64.rpm' に保存中

100%[==========================================================================================================================================>] 565,728      454K/s 時間 1.2s

2013-02-16 15:00:32 (454 KB/s) - `zabbix-java-gateway-2.0.5-1.el6.x86_64.rpm' へ保存完了 [565728/565728]
zabbix-serverをダウンロード
# wget http://repo.zabbix.com/zabbix/2.0/rhel/6/x86_64/zabbix-server-2.0.5-1.el6.x86_64.rpm
--2013-02-16 15:00:37--  http://www.kodai74.net/packages/zabbix/zabbix-2.0/rhel/6/x86_64/zabbix-server-2.0.5-1.el6.x86_64.rpm
www.kodai74.net をDNSに問いあわせています... 66.117.3.248
www.kodai74.net|66.117.3.248|:80 に接続しています... 接続しました。
HTTP による接続要求を送信しました、応答を待っています... 200 OK
長さ: 17984 (18K) [text/plain]
`zabbix-server-2.0.5-1.el6.x86_64.rpm' に保存中

100%[==========================================================================================================================================>] 17,984      --.-K/s 時間 0.1s

2013-02-16 15:00:37 (135 KB/s) - `zabbix-server-2.0.5-1.el6.x86_64.rpm' へ保存完了 [17984/17984]
zabbix-webをダウンロード
# wget http://repo.zabbix.com/zabbix/2.0/rhel/6/x86_64/zabbix-web-2.0.5-1.el6.noarch.rpm
--2013-02-16 15:00:44--  http://www.kodai74.net/packages/zabbix/zabbix-2.0/rhel/6/x86_64/zabbix-web-2.0.5-1.el6.noarch.rpm
www.kodai74.net をDNSに問いあわせています... 66.117.3.248
www.kodai74.net|66.117.3.248|:80 に接続しています... 接続しました。
HTTP による接続要求を送信しました、応答を待っています... 200 OK
長さ: 3646300 (3.5M) [text/plain]
`zabbix-web-2.0.5-1.el6.noarch.rpm' に保存中

100%[==========================================================================================================================================>] 3,646,300    520K/s 時間 7.2s

2013-02-16 15:00:52 (498 KB/s) - `zabbix-web-2.0.5-1.el6.noarch.rpm' へ保存完了 [3646300/3646300]
zabbix-web-japaneseをダウンロード
# wget http://repo.zabbix.com/zabbix/2.0/rhel/6/x86_64/zabbix-web-japanese-2.0.5-1.el6.noarch.rpm
--2013-02-16 15:00:53--  http://www.kodai74.net/packages/zabbix/zabbix-2.0/rhel/6/x86_64/zabbix-web-japanese-2.0.5-1.el6.noarch.rpm
www.kodai74.net をDNSに問いあわせています... 66.117.3.248
www.kodai74.net|66.117.3.248|:80 に接続しています... 接続しました。
HTTP による接続要求を送信しました、応答を待っています... 200 OK
長さ: 11688 (11K) [text/plain]
`zabbix-web-japanese-2.0.5-1.el6.noarch.rpm' に保存中

100%[==========================================================================================================================================>] 11,688      --.-K/s 時間 0s

2013-02-16 15:00:53 (43.3 MB/s) - `zabbix-web-japanese-2.0.5-1.el6.noarch.rpm' へ保存完了 [11688/11688]
zabbix-server-mysqlをダウンロード
# wget http://repo.zabbix.com/zabbix/2.0/rhel/6/x86_64/zabbix-server-mysql-2.0.5-1.el6.x86_64.rpm
--2013-02-16 15:05:07--  http://www.kodai74.net/packages/zabbix/zabbix-2.0/rhel/6/x86_64/zabbix-server-mysql-2.0.5-1.el6.x86_64.rpm
www.kodai74.net をDNSに問いあわせています... 66.117.3.248
www.kodai74.net|66.117.3.248|:80 に接続しています... 接続しました。
HTTP による接続要求を送信しました、応答を待っています... 200 OK
長さ: 1455252 (1.4M) [text/plain]
`zabbix-server-mysql-2.0.5-1.el6.x86_64.rpm' に保存中

89% [===========================================================================================================================>               ] 1,302,997    477K/s              h100%[==========================================================================================================================================>] 1,455,252    488K/s 時間 2.9s

2013-02-16 15:05:10 (488 KB/s) - `zabbix-server-mysql-2.0.5-1.el6.x86_64.rpm' へ保存完了 [1455252/1455252]
zabbix-web-mysqlをダウンロード
# wget http://repo.zabbix.com/zabbix/2.0/rhel/6/x86_64/zabbix-web-mysql-2.0.5-1.el6.noarch.rpm
--2013-02-16 15:05:24--  http://www.kodai74.net/packages/zabbix/zabbix-2.0/rhel/6/x86_64/zabbix-web-mysql-2.0.5-1.el6.noarch.rpm
www.kodai74.net をDNSに問いあわせています... 66.117.3.248
www.kodai74.net|66.117.3.248|:80 に接続しています... 接続しました。
HTTP による接続要求を送信しました、応答を待っています... 200 OK
長さ: 11440 (11K) [text/plain]
`zabbix-web-mysql-2.0.5-1.el6.noarch.rpm' に保存中

100%[==========================================================================================================================================>] 11,440      --.-K/s 時間 0.001s

2013-02-16 15:05:24 (19.3 MB/s) - `zabbix-web-mysql-2.0.5-1.el6.noarch.rpm' へ保存完了 [11440/11440]
ダウンロードが完了したら、インストールを行う。
# rpm -ivh zabbix-2.0.5-1.el6.x86_64.rpm
準備中...                ########################################### [100%]
   1:zabbix                 ########################################### [100%]
# rpm -ivh zabbix-agent-2.0.5-1.el6.x86_64.rpm
準備中...                ########################################### [100%]
   1:zabbix-agent           ########################################### [100%]
# rpm -ivh zabbix-get-2.0.5-1.el6.x86_64.rpm
準備中...                ########################################### [100%]
   1:zabbix-get             ########################################### [100%]
# rpm -ivh zabbix-java-gateway-2.0.5-1.el6.x86_64.rpm
準備中...                ########################################### [100%]
   1:zabbix-java-gateway    ########################################### [100%]
次からは依存関係の問題で纏めてインストールする必要があるらしい。
# rpm -ivh zabbix-server-2.0.5-1.el6.x86_64.rpm zabbix-server-mysql-2.0.5-1.el6.x86_64.rpm
準備中...                ########################################### [100%]
   1:zabbix-server-mysql    ########################################### [ 50%]
   2:zabbix-server          ########################################### [100%]
# rpm -ivh zabbix-web-2.0.5-1.el6.noarch.rpm zabbix-web-mysql-2.0.5-1.el6.noarch.rpm zabbix-web-japanese-2.0.5-1.el6.noarch.rpm
準備中...                ########################################### [100%]
   1:zabbix-web-mysql       ########################################### [ 33%]
   2:zabbix-web             ########################################### [ 67%]
   3:zabbix-web-japanese    ########################################### [100%]
■Zabbixで利用するMySQLの初期化
初期設定などはこちらを参考にしてください。
#起動
# mysql -u root
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 3
Server version: 5.5.30-log MySQL Community Server (GPL) by Remi

Copyright (c) 2000, 2013, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.
#zabbix用のテーブル作成
mysql> create database zabbix character set utf8;
Query OK, 1 row affected (0.01 sec)

#zabbixのユーザー作成
mysql> grant all privileges on zabbix.* to zabbix@localhost identified by 'zabbix';
Query OK, 0 rows affected (0.03 sec)

#
mysql> Ctrl-C -- exit!
Aborted
#インポート
mysql -uroot zabbix < /usr/share/doc/zabbix-server-mysql-2.0.5/create/schema.sql

#インポート
mysql -uroot zabbix < /usr/share/doc/zabbix-server-mysql-2.0.5/create/images.sql

#インポート
mysql -uroot zabbix < /usr/share/doc/zabbix-server-mysql-2.0.5/create/data.sql
■zabbx serverの設定
デフォルト設定ファイルのバックアップを取っておく
cp /etc/zabbix/zabbix_server.conf zabbix_server.conf.org
設定ファイルの「DBPassword」の項目がコメントアウトされているので外して、
先程MySQLに設定したパスワードを設定する。
※116行目辺り
vi /etc/zabbix/zabbix_server.conf
    113 # Mandatory: no
    114 # Default:
    115 # DBPassword=
    116 DBPassword=zabbix
■zabbixサーバーの起動
zabbixサーバーを起動させる。
#zabbix-serverの起動
# service zabbix-server start
Starting Zabbix server:                                    [  OK  ]

#zabbix-agentの起動
# service zabbix-agent start
Starting Zabbix agent:                                     [  OK  ]
自動起動をONにする。
#
chkconfig zabbix-server on

#
chkconfig zabbix-agent on
■php.iniの編集
コメントアウトされているtimezoneの設定に「Asia/Tokyo」を設定する。
vi /etc/php.ini
    875 [Date]
    876 ; Defines the default timezone used by the date functions
    877 ; http://php.net/date.timezone
    878 date.timezone = Asia/Tokyo
apacheの再起動を行う。
#
apachectl restart
■server-statusを見れるようにする。
# /etc/init.d/httpd status
httpd (pid  2969) を実行中...
apachectl statuを実行すると次のようなエラーが発生してしましたました(´;ω;`)ウッ…
# apachectl status
The 'links' package is required for this functionality.
elinksが無いそうなのでインストールする
# yum install elinks
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * base: ftp.nara.wide.ad.jp
 * centosplus: ftp.nara.wide.ad.jp
 * elrepo: repos.lax-noc.com
 * epel: ftp.iij.ad.jp
 * extras: ftp.nara.wide.ad.jp
 * rpmforge: mirror.fairway.ne.jp
 * updates: ftp.nara.wide.ad.jp
169 packages excluded due to repository priority protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package elinks.x86_64 0:0.12-0.21.pre5.el6_3 will be installed
--> Processing Dependency: libnss_compat_ossl.so.0()(64bit) for package: elinks-0.12-0.21.pre5.el6_3.x86_64
--> Running transaction check
---> Package nss_compat_ossl.x86_64 0:0.9.6-1.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

====================================================================================================================================================================================
 Package                                       Arch                                 Version                                             Repository                             Size
====================================================================================================================================================================================
Installing:
 elinks                                        x86_64                               0.12-0.21.pre5.el6_3                                updates                               838 k
Installing for dependencies:
 nss_compat_ossl                               x86_64                               0.9.6-1.el6                                         base                                   34 k

Transaction Summary
====================================================================================================================================================================================
Install       2 Package(s)

Total download size: 871 k
Installed size: 2.6 M
Is this ok [y/N]: y
Downloading Packages:
(1/2): elinks-0.12-0.21.pre5.el6_3.x86_64.rpm                                                                                                                | 838 kB     00:00
(2/2): nss_compat_ossl-0.9.6-1.el6.x86_64.rpm                                                                                                                |  34 kB     00:00
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                               5.9 MB/s | 871 kB     00:00
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Warning: RPMDB altered outside of yum.
  Installing : nss_compat_ossl-0.9.6-1.el6.x86_64                                                                                                                               1/2
  Installing : elinks-0.12-0.21.pre5.el6_3.x86_64                                                                                                                               2/2
  Verifying  : nss_compat_ossl-0.9.6-1.el6.x86_64                                                                                                                               1/2
  Verifying  : elinks-0.12-0.21.pre5.el6_3.x86_64                                                                                                                               2/2

Installed:
  elinks.x86_64 0:0.12-0.21.pre5.el6_3

Dependency Installed:
  nss_compat_ossl.x86_64 0:0.9.6-1.el6

Complete!
もう一度実行して確認してみる:(;゙゚'ω゚'):
# apachectl status
                                   Not Found

   The requested URL /server-status was not found on this server.

   --------------------------------------------------------------------------

    Apache/2.2.15 (CentOS) Server at localhost Port 80
今度は、URLが見つからないよ?的なことなので、
また設定ファイルの次の部分を編集します。
921行目あたりにある、server-statusの定義がコメントアウトされているので全て外す。
また、「Allow from .example.com」を「 Allow from localhost」に変更する。
    921 
    922     SetHandler server-status
    923     Order deny,allow
    924     Deny from all
    925     Allow from localhost
    926 
再起動する。
# apachectl restart
再度、statusを実行してみると・・・
#
# apachectl status
                       Apache Server Status for localhost

   Server Version: Apache/2.2.15 (Unix) DAV/2 PHP/5.4.11

   Server Built: Feb 13 2012 22:31:42

   --------------------------------------------------------------------------

   Current Time: Saturday, 16-Feb-2013 15:47:54 JST

   Restart Time: Saturday, 16-Feb-2013 15:47:46 JST

   Parent Server Generation: 5

   Server uptime: 8 seconds

   1 requests currently being processed, 0 idle workers

 W.........

   Scoreboard Key:
   "_" Waiting for Connection, "S" Starting up, "R" Reading Request,
   "W" Sending Reply, "K" Keepalive (read), "D" DNS Lookup,
   "C" Closing connection, "L" Logging, "G" Gracefully finishing,
   "I" Idle cleanup of worker, "." Open slot with no current process
キタ――(゚∀゚)――!!

以上(`・ω・´)ゞビシッ!!

参考URL

0 件のコメント:

コメントを投稿