2012年10月11日木曜日

zabbixのインストール

監視ツールとしてzabbixをインストールする。 zabbixの最新版を確認する
CentOS 5用 64bit版
CentOS 6用 64bit版
■手順1)yumリポジトリ用RPMをインストールする 今回は、CentOS6の64bit版なので、
rpm -ihv http://www.zabbix.jp/binaries/relatedpkgs/rhel6/x86_64/zabbix-jp-release-6-5.noarch.rpm
http://www.zabbix.jp/binaries/relatedpkgs/rhel6/x86_64/zabbix-jp-release-6-5.noarch.rpm を取得中
curl: (22) The requested URL returned error: 404
あれ・・・エラーになる(´;ω;`)ウッ… 一度ダウンロードする
# wget http://www.zabbix.jp/binaries/relatedpkgs/rhel6/x86_64/zabbix-jp-release-6-5.noarch.rpm
--2012-10-11 02:35:09--  http://www.zabbix.jp/binaries/relatedpkgs/rhel6/x86_64/zabbix-jp-release-6-5.noarch.rpm
www.zabbix.jp をDNSに問いあわせています... 173.247.250.112
www.zabbix.jp|173.247.250.112|:80 に接続しています... 接続しました。
HTTP による接続要求を送信しました、応答を待っています... 200 OK
長さ: 13752 (13K) [text/plain]
`zabbix-jp-release-6-5.noarch.rpm' に保存中

100%[=====================================================================================================================================================================================>] 13,752      46.2K/s 時間 0.3s

2012-10-11 02:35:10 (46.2 KB/s) - `zabbix-jp-release-6-5.noarch.rpm' へ保存完了 [13752/13752]
(σ・∀・)σゲッツ!!
インストールする。
# rpm -ihv zabbix-jp-release-6-5.noarch.rpm
警告: zabbix-jp-release-6-5.noarch.rpm: ヘッダ V4 DSA/SHA1 Signature, key ID f32904ff: NOKEY
準備中...                ########################################### [100%]
   1:zabbix-jp-release      ########################################### [100%]
■手順2)インストールされるバージョンを確認
alternatives --display zabbix-jp-release
zabbix-jp-release -ステータスは自動です。
リンクは現在 /usr/share/zabbix-jp-release/zabbix-jp-1.8.repo を指しています。
/usr/share/zabbix-jp-release/zabbix-jp-1.1.repo - 優先項目 10
/usr/share/zabbix-jp-release/zabbix-jp-1.4.repo - 優先項目 20
/usr/share/zabbix-jp-release/zabbix-jp-1.6.repo - 優先項目 30
/usr/share/zabbix-jp-release/zabbix-jp-1.8.repo - 優先項目 40
現在の「最適」バージョンは /usr/share/zabbix-jp-release/zabbix-jp-1.8.repo です。
最新版の1.8が指定されているのでそのままにする。
もし、最新版じゃなかった場合には、
alternatives --config zabbix-jp-release
を実行して、最新版の番号を選択することで変更が可能。

■手順3)zabbixをインストールする
64bit版をインストールする。(zabbixで必要なphpやmysqlなどがインストールされる)
yum install zabbix.x86_64 zabbix-agent.x86_64 zabbix-server.x86_64 zabbix-server-mysql.x86_64 zabbix-web.x86_64 zabbix-web-mysql.x86_64

Installed:
  zabbix.x86_64 0:1.8.15-1.el6.JP               zabbix-agent.x86_64 0:1.8.15-1.el6.JP     zabbix-server.x86_64 0:1.8.15-1.el6.JP     zabbix-server-mysql.x86_64 0:1.8.15-1.el6.JP     zabbix-web.x86_64 0:1.8.15-1.el6.JP
  zabbix-web-mysql.x86_64 0:1.8.15-1.el6.JP

Dependency Installed:
  OpenIPMI-libs.x86_64 0:2.0.16-12.el6   fping.x86_64 0:3.1-1.el6.rf          iksemel.x86_64 0:1.4-2.el6.JP     libXpm.x86_64 0:3.5.8-2.el6          mysql.x86_64 0:5.1.61-4.el6      mysql-libs.x86_64 0:5.1.61-4.el6
  php.x86_64 0:5.3.3-14.el6_3            php-bcmath.x86_64 0:5.3.3-14.el6_3   php-cli.x86_64 0:5.3.3-14.el6_3   php-common.x86_64 0:5.3.3-14.el6_3   php-gd.x86_64 0:5.3.3-14.el6_3   php-mbstring.x86_64 0:5.3.3-14.el6_3
  php-mysql.x86_64 0:5.3.3-14.el6_3      php-pdo.x86_64 0:5.3.3-14.el6_3      php-xml.x86_64 0:5.3.3-14.el6_3   unixODBC.x86_64 0:2.2.14-11.el6

Complete!

0 件のコメント:

コメントを投稿